US Data Center - Services unavailable.
Incident Report for Solver
Postmortem

Microsoft has posted the following root cause of the incident:

We’ve determined the underlying cause. A backend cluster management workflow deployed a configuration change causing backend access to be blocked between a subset of Azure Storage clusters and compute resources in the Central US region. This resulted in the compute resources automatically restarting when connectivity was lost to virtual disks. Mitigation has been confirmed for all Azure Storage clusters, the majority of services are now recovered. A small subset of services is still experiencing residual impact. Impacted customers will be continuing to communicate through the Azure service health portal.

reference: https://azure.status.microsoft/en-us/status/history/

Posted Jul 18, 2024 - 23:43 PDT

Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 22:38 PDT
Monitoring
US Production services have been restored. Microsoft Azure is still reporting an outage but Solver systems are functioning as expected. We will continue to monitor all services. We will share information from Microsoft as it becomes available.
Reference: https://azure.status.microsoft/en-us/status

This notification is being sent to all status page subscribers. However, the outage has only impacted customers using the US environment. https://us.app.solverglobal.com/
Posted Jul 18, 2024 - 19:26 PDT
Update
The Microsoft outage is still ongoing. However, they have identified the issue and are currently working to restore services. The Solver cloud engineers have initiated contingency plans to restore services.

reference: https://azure.status.microsoft/en-us/status
Posted Jul 18, 2024 - 19:13 PDT
Update
We continue to monitor Microsoft for updates on this outage and will restore US services as soon as possible. We will continue to update this status site. Microsoft is also updating their site here: https://azure.status.microsoft/en-us/status
Posted Jul 18, 2024 - 16:29 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 15:56 PDT
Identified
We have identified this is an outage with Microsoft Azure hosting. We are working to restore services as quickly as possible.
Posted Jul 18, 2024 - 15:47 PDT
Investigating
We are currently investigating this issue.
Posted Jul 18, 2024 - 15:36 PDT
This incident affected: US Cloud (Website, Report Rendering Service, Data Services).