US - Integrations and Jobs performance degradation

Incident Report for Solver

Resolved

This incident has been resolved. We will continue to monitor the environment to ensure stability and performance.
Posted Jul 13, 2026 - 15:52 PDT

Update

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 10:33 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 10:28 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 13, 2026 - 08:18 PDT

Update

We are continuing to investigate this issue.
Posted Jul 13, 2026 - 07:07 PDT

Investigating

We are currently investigating this issue.
Posted Jul 13, 2026 - 06:06 PDT
This incident affected: US Cloud (Data Services).